org.apache.portals.jetspeed-2:jetspeed-security@2.2.1 vulnerabilities

Jetspeed-2 Security Components

Direct Vulnerabilities

Known vulnerabilities in the org.apache.portals.jetspeed-2:jetspeed-security package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Arbitrary User Modification

org.apache.portals.jetspeed-2:jetspeed-security The User Manager service in Apache Jetspeed before 2.3.1 does not properly restrict access using Jetspeed Security, which allows remote attackers to (1) add, (2) edit, or (3) delete users via the REST API.

(,2.3.1)
  • H
SQL Injection

org.apache.portals.jetspeed-2:jetspeed-security Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.

(,2.3.1)