org.apache.syncope.core:syncope-core-provisioning-java@2.0.11 vulnerabilities

Apache Syncope Core Provisioning Java

Direct Vulnerabilities

Known vulnerabilities in the org.apache.syncope.core:syncope-core-provisioning-java package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Remote Code Execution (RCE)

org.apache.syncope.core:syncope-core-provisioning-java is an Open Source system for managing digital identities in enterprise environments, implemented in Java EE technology and released under Apache 2.0 license.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). Server-Side Template Injection on Mail templates enabling attackers to inject arbitrary JEXL expressions, leading to Remote Code Execution.

How to fix Remote Code Execution (RCE)?

Upgrade org.apache.syncope.core:syncope-core-provisioning-java to version 2.0.15, 2.1.6 or higher.

[2.0.0,2.0.15) [2.1.0,2.1.6)