Remote Code Execution (RCE) Affecting org.apache.syncope.core:syncope-core-provisioning-java Open this link in a new tab package, versions [2.0.0, 2.0.15) [2.1.0, 2.1.6)


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESYNCOPECORE-568077

  • published

    4 May 2020

  • disclosed

    4 May 2020

  • credit

    Unknown

How to fix?

Upgrade org.apache.syncope.core:syncope-core-provisioning-java to version 2.0.15, 2.1.6 or higher.

Overview

org.apache.syncope.core:syncope-core-provisioning-java is an Open Source system for managing digital identities in enterprise environments, implemented in Java EE technology and released under Apache 2.0 license.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). Server-Side Template Injection on Mail templates enabling attackers to inject arbitrary JEXL expressions, leading to Remote Code Execution.