@apostrophecms/form@1.5.4

Build forms for ApostropheCMS in a simple user interface.

  • latest version

    1.5.6

  • latest non vulnerable version

  • first published

    5 years ago

  • latest version published

    12 days ago

  • licenses detected

  • Direct Vulnerabilities

    Known vulnerabilities in the @apostrophecms/form package. This does not include vulnerabilities belonging to this package’s dependencies.

    Fix vulnerabilities automatically

    Snyk's AI Trust Platform automatically finds the best upgrade path and integrates with your development workflows. Secure your code at zero cost.

    Fix for free
    VulnerabilityVulnerable Version
    • M
    Improper Encoding or Escaping of Output

    @apostrophecms/form is a Build forms for ApostropheCMS in a simple user interface.

    Affected versions of this package are vulnerable to Improper Encoding or Escaping of Output via insufficient enforcement of hCaptcha verification in the login flow, allowing an authenticated low-privileged attacker to bypass the CAPTCHA challenge and gain unauthorized access to protected resources with limited confidentiality, integrity, and availability impact.

    How to fix Improper Encoding or Escaping of Output?

    Upgrade @apostrophecms/form to version 1.5.5 or higher.

    <1.5.5
    • M
    Allocation of Resources Without Limits or Throttling

    @apostrophecms/form is a Build forms for ApostropheCMS in a simple user interface.

    Affected versions of this package are vulnerable to Allocation of Resources Without Limits or Throttling via an unspecified vector in the form submission handling logic, allowing a remote unauthenticated attacker to degrade service availability.

    How to fix Allocation of Resources Without Limits or Throttling?

    Upgrade @apostrophecms/form to version 1.5.5 or higher.

    <1.5.5