@theia/mini-browser@0.4.0-next.35f009ba vulnerabilities

Theia - Mini-Browser Extension

  • latest version

    1.47.0

  • latest non vulnerable version

  • first published

    6 years ago

  • latest version published

    13 hours ago

  • licenses detected

    • >=0.3.12 <0.4.0-next.30302288; >=0.4.0-next.37497648 <0.4.0-next.70567252; >=0.4.0-next.80121840 <0.4.0-next.0452f917; >=0.4.0-next.04887acb <0.4.0-next.05b8a1fe; >=0.4.0-next.07a449af <0.4.0-next.089eacb1; >=0.4.0-next.09095b06 <0.4.0-next.0a3cf52b; >=0.4.0-next.0a6abc41 <0.4.0-next.0af15439; >=0.4.0-next.0c4794d1 <0.4.0-next.0ce7265a; >=0.4.0-next.0cf80336 <0.4.0-next.0e8227b1; >=0.4.0-next.0ea61827 <0.4.0-next.11e5c508; >=0.4.0-next.11f9f570 <0.4.0-next.190734a5; >=0.4.0-next.19a8cfef <0.4.0-next.1a3d9ace; >=0.4.0-next.1c202843 <0.4.0-next.1c6a289d; >=0.4.0-next.1ca7db0a <0.4.0-next.2751e6aa; >=0.4.0-next.28692d8d <0.4.0-next.2bec2948; >=0.4.0-next.2c9cbbe2 <0.4.0-next.317ec35d; >=0.4.0-next.31c19d22 <0.4.0-next.3216adc8; >=0.4.0-next.322e9307 <0.4.0-next.3241dd5f; >=0.4.0-next.3302096b <0.4.0-next.33548c4b; >=0.4.0-next.337c62d5 <0.4.0-next.3ad1b934; >=0.4.0-next.3b4c459b <0.4.0-next.3cc63739; >=0.4.0-next.3ce6b1a0 <0.4.0-next.3fa31f9f; >=0.4.0-next.3fbd5e55 <0.4.0-next.421041cf; >=0.4.0-next.4303a25f <0.4.0-next.448cbac3; >=0.4.0-next.4572886d <0.4.0-next.48a4697f; >=0.4.0-next.48aeff5a <0.4.0-next.4996f9be; >=0.4.0-next.49db4e46 <0.4.0-next.4ce7eca4; >=0.4.0-next.4deb67ed <0.4.0-next.4df0bc53; >=0.4.0-next.4e1bc9eb <0.4.0-next.4e6c39f1; >=0.4.0-next.4eb37604 <0.4.0-next.4f42f169; >=0.4.0-next.4f67b025 <0.4.0-next.50e1faa0; >=0.4.0-next.51010edc <0.4.0-next.51e75fbe; >=0.4.0-next.523426dd <0.4.0-next.531db028; >=0.4.0-next.5336443c <0.4.0-next.5508eba5; >=0.4.0-next.558d4b53 <0.4.0-next.56b94e68; >=0.4.0-next.57b8add5 <0.4.0-next.588f4e0e; >=0.4.0-next.5928c2d4 <0.4.0-next.59a1a3aa; >=0.4.0-next.5a60919f <0.4.0-next.5c83d58f; >=0.4.0-next.5d429ebf <0.4.0-next.6c696aeb; >=0.4.0-next.6cb7b7e5 <0.4.0-next.7039ddf6; >=0.4.0-next.705a376b <0.4.0-next.73aee16d; >=0.4.0-next.73d23a46 <0.4.0-next.750ffc54; >=0.4.0-next.75422c87 <0.4.0-next.77fd859f; >=0.4.0-next.7979da88 <0.4.0-next.7b3e0122; >=0.4.0-next.7bc62190 <0.4.0-next.7caa4c87; >=0.4.0-next.7cf3ca76 <0.4.0-next.7da249dd; >=0.4.0-next.7df95eb5 <0.4.0-next.7e9b2085; >=0.4.0-next.7f0b33d9 <0.4.0-next.8384ef22; >=0.4.0-next.842196b5 <0.4.0-next.8509100c; >=0.4.0-next.85890fd3 <0.4.0-next.86654a02; >=0.4.0-next.86a6c9ee <0.4.0-next.8712381a; >=0.4.0-next.8748b355 <0.4.0-next.8a5132e5; >=0.4.0-next.8a8bf17e <0.4.0-next.8ab83bde; >=0.4.0-next.8adf4a6d <0.4.0-next.8cc44ca2; >=0.4.0-next.8d151a6d <0.4.0-next.8e00cb0d; >=0.4.0-next.8ecf40e1 <0.4.0-next.9694094c; >=0.4.0-next.96ed159b <0.4.0-next.96f90b8c; >=0.4.0-next.971b4219 <0.4.0-next.9b95d4f0; >=0.4.0-next.9c293b46 <0.4.0-next.9fc35c5a; >=0.4.0-next.a09db28d <0.4.0-next.a1b99b91; >=0.4.0-next.a2119bc9 <0.4.0-next.a2df2faf; >=0.4.0-next.a2fa9040 <0.4.0-next.a34acb83; >=0.4.0-next.a37b81d0 <0.4.0-next.a52fab7d; >=0.4.0-next.a5a1683c <0.4.0-next.a7a0c72a; >=0.4.0-next.a821f30a <0.4.0-next.a831a03c; >=0.4.0-next.a83fb710 <0.4.0-next.a84e6fe1; >=0.4.0-next.a88cb19a <0.4.0-next.a9a0fc30; >=0.4.0-next.a9cf7d8d <0.4.0-next.aa7754c9; >=0.4.0-next.aa9a92d2 <0.4.0-next.b3b6681a; >=0.4.0-next.b3b678fb <0.4.0-next.b3f2b347; >=0.4.0-next.b4397500 <0.4.0-next.b531e562; >=0.4.0-next.b56b7acd <0.4.0-next.c1867413; >=0.4.0-next.c1adcdfe <0.4.0-next.c45b1f60; >=0.4.0-next.c5554c8a <0.4.0-next.ca5e7962; >=0.4.0-next.cb9fc532 <0.4.0-next.d4a0b0aa; >=0.4.0-next.d563b31a <0.4.0-next.db9ee3eb; >=0.4.0-next.dc12d6db <0.4.0-next.dc6ac888; >=0.4.0-next.dcc328c2 <0.4.0-next.de618c7d; >=0.4.0-next.ded32dc6 <0.4.0-next.e20742c8; >=0.4.0-next.e25aa8d6 <0.4.0-next.e2e8d9d7; >=0.4.0-next.e2f3ec66 <0.4.0-next.e7eb69fc; >=0.4.0-next.e8646eac <0.4.0-next.ea95903c; >=0.4.0-next.eab60a0e <0.4.0-next.ec5f7b16; >=0.4.0-next.ecd79892 <0.4.0-next.ef000bd1; >=0.4.0-next.f030da0c <0.4.0-next.f6e320d8; >=0.4.0-next.f6ee123d <0.4.0-next.f98eb08f; >=0.4.0-next.f9ae69d1 <1.39.0-next.16

Direct Vulnerabilities

Known vulnerabilities in the @theia/mini-browser package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Arbitrary Code Execution

@theia/mini-browser is a Theia - Mini-Browser Extension

Affected versions of this package are vulnerable to Arbitrary Code Execution. In Eclipse Theia, the "mini-browser" extension allows a user to preview HTML files in an iframe inside the IDE. But with the way it is made it is possible for a previewed HTML file to trigger an RCE. This exploit only happens if a user previews a malicious file.

How to fix Arbitrary Code Execution?

Upgrade @theia/mini-browser to version 1.9.0 or higher.

>=0.3.9 <1.9.0
  • H
Information Exposure

@theia/mini-browser is a Theia - Mini-Browser Extension

Affected versions of this package are vulnerable to Information Exposure. This extension exposes a HTTP endpoint that allows to read the content of files on the hosts filesystem, given their path, without restrictions on the requester's origin. This design is vulnerable to being exploited remotely through a DNS rebinding attack or a drive-by download of a carefully crafted exploit.

How to fix Information Exposure?

Upgrade @theia/mini-browser to version 0.16.0 or higher.

>=0.3.9 <0.16.0