Arbitrary Code Execution Affecting @theia/mini-browser package, versions >=0.3.9 <1.9.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.23% (61st percentile)
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-THEIAMINIBROWSER-1582379
  • published 3 Sep 2021
  • disclosed 2 Sep 2021
  • credit Unknown

How to fix?

Upgrade @theia/mini-browser to version 1.9.0 or higher.

Overview

@theia/mini-browser is a Theia - Mini-Browser Extension

Affected versions of this package are vulnerable to Arbitrary Code Execution. In Eclipse Theia, the "mini-browser" extension allows a user to preview HTML files in an iframe inside the IDE. But with the way it is made it is possible for a previewed HTML file to trigger an RCE. This exploit only happens if a user previews a malicious file.