ckeditor4@4.15.1 vulnerabilities

JavaScript WYSIWYG web text editor.

Direct Vulnerabilities

Known vulnerabilities in the ckeditor4 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via malformed HTML injection to the core HTML processing module, which may allow execution of JavaScript code.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.18.0 or higher.

<4.18.0
  • H
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the core HTML processing module and may affect all plugins used by the package.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.17.0 or higher.

<4.17.0
  • H
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the Advanced Content Filter (ACF) module and may affect all plugins used by the package.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.17.0 or higher.

<4.17.0
  • M
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). A vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.16.2 or higher.

<4.16.2
  • H
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). A vulnerability has been discovered in CKEditor 4 Fake Objects package. The vulnerability allowed to inject malformed Fake Objects HTML, which could result in executing JavaScript code.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.16.2 or higher.

<4.16.2
  • H
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.16.2 or higher.

<4.16.2
  • M
Cross-site Scripting (XSS)

ckeditor4 is a JavaScript WYSIWYG web text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

How to fix Cross-site Scripting (XSS)?

Upgrade ckeditor4 to version 4.16.1 or higher.

>=4.14.0 <4.16.1