gatsby@0.12.38 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the gatsby package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Information Exposure

gatsby is a framework based on React that helps developers build blazing fast websites and apps

Affected versions of this package are vulnerable to Information Exposure via local file inclusion in __file-code-frame or __original-stack-frame, when gatsby develop is in use and exposed to the internet.

NOTE: By default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBY_HOST=0.0.0.0 environment variable.

How to fix Information Exposure?

Upgrade gatsby to version 4.25.7, 5.9.1 or higher.

<4.25.7 >=5.0.0 <5.9.1