Information Exposure Affecting gatsby package, versions <4.25.7 >=5.0.0 <5.9.1



    Attack Complexity Low

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.06% (24th percentile)
Expand this section
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GATSBY-5671647
  • published 8 Jun 2023
  • disclosed 8 Jun 2023
  • credit Maxwell Garrett

How to fix?

Upgrade gatsby to version 4.25.7, 5.9.1 or higher.


gatsby is a framework based on React that helps developers build blazing fast websites and apps

Affected versions of this package are vulnerable to Information Exposure via local file inclusion in __file-code-frame or __original-stack-frame, when gatsby develop is in use and exposed to the internet.

NOTE: By default gatsby develop is only accessible via the localhost, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host, -H, or the GATSBY_HOST= environment variable.


# Local File Inclusion in __file-code-frame
$ curl ""

# Local File Inclusion in __original-stack-frame
$ curl ""