actionview vulnerabilities

Simple, battle-tested conventions and helpers for building web pages.

Direct Vulnerabilities

Known vulnerabilities in the actionview package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

<5.2.7.1 >=6.0.0.beta1, <6.0.4.8 >=6.1.0.rc1, <6.1.5.1 >=7.0.0.alpha1, <7.0.2.4
  • M
Cross-site Scripting (XSS)

<5.2.4.4 >=6.0.0.0, <6.0.3.3
  • M
Cross-site Request Forgery (CSRF)

<5.2.4.3 >=6.0.0, <6.0.3.1
  • C
Remote Code Execution (RCE)

<4.2.11.3 >=5.0.0, <5.0.1
  • M
Cross-site Scripting (XSS)

<5.2.4.2 >=6.0.0, <6.0.2.2
  • M
Arbitrary File Read

>=4.2.11, <4.2.11.1 >=5.0.7, <5.0.7.2 >=5.1.6, <5.1.6.2 >=5.2.2, <5.2.2.1
  • M
Denial of Service (DoS)

>=4.2.11, <4.2.11.1 >=5.0.7, <5.0.7.2 >=5.1.6, <5.1.6.2 >=5.2.2, <5.2.2.1
  • M
Cross-site Scripting (XSS)

>=5.0.0.0, <5.0.0.1 >=3.2.23, <4.2.7.1 >=3.0.0, <3.2.22.3
  • M
Information Exposure

>=3.2.23, <4.1.14.2 <3.2.22.2
  • H
Information Exposure

>=4.3.0, <5.0.0 >=4.2.0, <4.2.5.1 >=3.2.23, <4.1.14.1 <3.2.22.1