Remote Code Execution (RCE) Affecting actionview package, versions <4.2.11.3 >=5.0.0, <5.0.1


0.0
critical
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIONVIEW-569156

  • published

    17 May 2020

  • disclosed

    17 May 2020

  • credit

    Unknown

How to fix?

Upgrade actionview to version 4.2.11.3, 5.0.1 or higher.

Overview

actionview is a simple, battle-tested conventions and helpers for building web pages.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). An attacker might be able to control the locals argument of a render call.

Note: It doesn't affect applications that don't allow users to control the names of locals.