CVE-2017-1000083 Affecting evince package, versions <3.24.0-r2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
51.08% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE310-EVINCE-454831
  • published5 Sept 2017
  • disclosed5 Sept 2017

Introduced: 5 Sep 2017

CVE-2017-1000083  (opens in a new tab)

How to fix?

Upgrade Alpine:3.10 evince to version 3.24.0-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evince package and not the evince package as distributed by Alpine. See How to fix? for Alpine:3.10 relevant fixed versions and status.

backend/comics/comics-document.c (aka the comic book backend) in GNOME Evince before 3.24.1 allows remote attackers to execute arbitrary commands via a .cbt file that is a TAR archive containing a filename beginning with a "--" command-line option substring, as demonstrated by a --checkpoint-action=exec=bash at the beginning of the filename.