Link Following Affecting libxfont2 package, versions <2.0.3-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE310-LIBXFONT2-454459
  • published1 Dec 2017
  • disclosed1 Dec 2017

Introduced: 1 Dec 2017

CVE-2017-16611  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Alpine:3.10 libxfont2 to version 2.0.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxfont2 package and not the libxfont2 package as distributed by Alpine. See How to fix? for Alpine:3.10 relevant fixed versions and status.

In libXfont before 1.5.4 and libXfont2 before 2.0.3, a local attacker can open (but not read) files on the system as root, triggering tape rewinds, watchdogs, or similar mechanisms that can be triggered by opening files.

CVSS Base Scores

version 3.1