Insufficient Entropy Affecting gcc package, versions <9.3.0-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.18% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE311-GCC-598616
  • published14 Aug 2020
  • disclosed2 Sept 2019

Introduced: 2 Sep 2019

CVE-2019-15847  (opens in a new tab)
CWE-331  (opens in a new tab)

How to fix?

Upgrade Alpine:3.11 gcc to version 9.3.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcc package and not the gcc package as distributed by Alpine. See How to fix? for Alpine:3.11 relevant fixed versions and status.

The POWER9 backend in GNU Compiler Collection (GCC) before version 10 could optimize multiple calls of the __builtin_darn intrinsic into a single call, thus reducing the entropy of the random number generator. This occurred because a volatile operation was not specified. For example, within a single execution of a program, the output of every __builtin_darn() call may be the same.

CVSS Base Scores

version 3.1