Cryptographic Issues Affecting libgcrypt package, versions <1.8.4-r2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.21% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE311-LIBGCRYPT-545037
  • published23 Jun 2019
  • disclosed20 Jun 2019

Introduced: 20 Jun 2019

CVE-2019-12904  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Alpine:3.11 libgcrypt to version 1.8.4-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt package and not the libgcrypt package as distributed by Alpine. See How to fix? for Alpine:3.11 relevant fixed versions and status.

In Libgcrypt 1.8.4, the C implementation of AES is vulnerable to a flush-and-reload side-channel attack because physical addresses are available to other processes. (The C implementation is used on platforms where an assembly-language implementation is unavailable.) NOTE: the vendor's position is that the issue report cannot be validated because there is no description of an attack

CVSS Base Scores

version 3.1