Out-of-bounds Read Affecting py-pillow package, versions <6.2.1-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.24% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE311-PYPILLOW-1924616
  • published22 Nov 2021
  • disclosed3 Sept 2021

Introduced: 3 Sep 2021

CVE-2021-23437  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Alpine:3.11 py-pillow to version 6.2.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py-pillow package and not the py-pillow package as distributed by Alpine. See How to fix? for Alpine:3.11 relevant fixed versions and status.

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

CVSS Base Scores

version 3.1