Out-of-bounds Write Affecting vlc package, versions <3.0.9.2-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.17% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE311-VLC-596328
  • published30 Jul 2020
  • disclosed13 Jul 2021

Introduced: 30 Jul 2020

CVE-2020-19721  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Alpine:3.11 vlc to version 3.0.9.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vlc package and not the vlc package as distributed by Alpine. See How to fix? for Alpine:3.11 relevant fixed versions and status.

A heap buffer overflow vulnerability in Ap4TrunAtom.cpp of Bento 1.5.1-628 may lead to an out-of-bounds write while running mp42aac, leading to system crashes and a denial of service (DOS).

CVSS Base Scores

version 3.1