Improper Privilege Management Affecting bluez package, versions <5.54-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.04% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE312-BLUEZ-589578
  • published21 Jul 2020
  • disclosed12 Mar 2020

Introduced: 12 Mar 2020

CVE-2020-0556  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Alpine:3.12 bluez to version 5.54-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bluez package and not the bluez package as distributed by Alpine. See How to fix? for Alpine:3.12 relevant fixed versions and status.

Improper access control in subsystem for BlueZ before version 5.54 may allow an unauthenticated user to potentially enable escalation of privilege and denial of service via adjacent access

CVSS Base Scores

version 3.1