CVE-2021-40330 Affecting git package, versions <2.26.3-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.87% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE312-GIT-2423385
  • published15 Mar 2022
  • disclosed31 Aug 2021

Introduced: 31 Aug 2021

CVE-2021-40330  (opens in a new tab)

How to fix?

Upgrade Alpine:3.12 git to version 2.26.3-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream git package and not the git package as distributed by Alpine. See How to fix? for Alpine:3.12 relevant fixed versions and status.

git_connect_git in connect.c in Git before 2.30.1 allows a repository path to contain a newline character, which may result in unexpected cross-protocol requests, as demonstrated by the git://localhost:1234/%0d%0a%0d%0aGET%20/%20HTTP/1.1 substring.

CVSS Base Scores

version 3.1