Uncontrolled Recursion Affecting krb5 package, versions <1.18.3-r0



    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.52% (77th percentile)
Expand this section
7.5 high
Expand this section
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE312-KRB5-1043934
  • published 24 Nov 2020
  • disclosed 6 Nov 2020

How to fix?

Upgrade Alpine:3.12 krb5 to version 1.18.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream krb5 package and not the krb5 package as distributed by Alpine. See How to fix? for Alpine:3.12 relevant fixed versions and status.

MIT Kerberos 5 (aka krb5) before 1.17.2 and 1.18.x before 1.18.3 allows unbounded recursion via an ASN.1-encoded Kerberos message because the lib/krb5/asn.1/asn1_encode.c support for BER indefinite lengths lacks a recursion limit.