Use of a Broken or Risky Cryptographic Algorithm Affecting libgcrypt package, versions <1.8.8-r1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.42% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE312-LIBGCRYPT-1585258
  • published15 Sept 2021
  • disclosed6 Sept 2021

Introduced: 6 Sep 2021

CVE-2021-40528  (opens in a new tab)
CWE-327  (opens in a new tab)

How to fix?

Upgrade Alpine:3.12 libgcrypt to version 1.8.8-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt package and not the libgcrypt package as distributed by Alpine. See How to fix? for Alpine:3.12 relevant fixed versions and status.

The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.

CVSS Base Scores

version 3.1