Out-of-bounds Read Affecting luajit package, versions <2.2.0-r3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.13% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE313-LUAJIT-1067689
  • published2 Feb 2021
  • disclosed21 Jul 2020

Introduced: 21 Jul 2020

CVE-2020-15890  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Alpine:3.13 luajit to version 2.2.0-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream luajit package and not the luajit package as distributed by Alpine. See How to fix? for Alpine:3.13 relevant fixed versions and status.

LuaJit through 2.1.0-beta3 has an out-of-bounds read because __gc handler frame traversal is mishandled.

CVSS Base Scores

version 3.1