Out-of-bounds Write Affecting zlib package, versions <1.2.12-r0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
Red Hat
8.2 high
Expand this section
SUSE
8.1 high
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE313-ZLIB-2434418
  • published 29 Mar 2022
  • disclosed 25 Mar 2022

How to fix?

Upgrade Alpine:3.13 zlib to version 1.2.12-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream zlib package. See How to fix? for Alpine:3.13 relevant versions.

zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches.