Improper Authentication Affecting curl package, versions <7.79.1-r1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
Expand this section
SUSE
5.3 medium
Expand this section
NVD
8.1 high
Expand this section
RHEL
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE314-CURL-2804934
  • published 28 Apr 2022
  • disclosed 26 May 2022

How to fix?

Upgrade Alpine:3.14 curl to version 7.79.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Alpine:3.14 relevant versions.

An improper authentication vulnerability exists in curl 7.33.0 to and including 7.82.0 which might allow reuse OAUTH2-authenticated connections without properly making sure that the connection was authenticated with the same credentials as set for this transfer. This affects SASL-enabled protocols: SMPTP(S), IMAP(S), POP3(S) and LDAP(S) (openldap only).

References