CVE-2022-27775 Affecting curl package, versions <7.79.1-r1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
SUSE
5.6 medium
Expand this section
RHEL
2.6 low
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE314-CURL-2804941
  • published 28 Apr 2022
  • disclosed 2 Jun 2022

How to fix?

Upgrade Alpine:3.14 curl to version 7.79.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Alpine:3.14 relevant versions.

An information disclosure vulnerability exists in curl 7.65.0 to 7.82.0 are vulnerable that by using an IPv6 address that was in the connection pool but with a different zone id it could reuse a connection instead.

References