Out-of-bounds Write Affecting curl package, versions <7.79.1-r2


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High
Expand this section
RHEL
5.3 medium
Expand this section
SUSE
6.6 medium
Expand this section
NVD
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE314-CURL-2938015
  • published 30 Jun 2022
  • disclosed 7 Jul 2022

How to fix?

Upgrade Alpine:3.14 curl to version 7.79.1-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See How to fix? for Alpine:3.14 relevant versions.

When curl < 7.84.0 does FTP transfers secured by krb5, it handles message verification failures wrongly. This flaw makes it possible for a Man-In-The-Middle attack to go unnoticed and even allows it to inject data to the client.