Improper Privilege Management Affecting hylafaxplus package, versions <7.0.2-r2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.54% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE315-HYLAFAXPLUS-1927731
  • published29 Jul 2020
  • disclosed30 Jun 2020

Introduced: 30 Jun 2020

CVE-2020-15397  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Alpine:3.15 hylafaxplus to version 7.0.2-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hylafaxplus package and not the hylafaxplus package as distributed by Alpine. See How to fix? for Alpine:3.15 relevant fixed versions and status.

HylaFAX+ through 7.0.2 and HylaFAX Enterprise have scripts that execute binaries from directories writable by unprivileged users (e.g., locations under /var/spool/hylafax that are writable by the uucp account). This allows these users to execute code in the context of the user calling these binaries (often root).

CVSS Base Scores

version 3.1