Improper Authentication Affecting tinc package, versions <1.0.35-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.47% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE315-TINC-1929776
  • published9 Oct 2018
  • disclosed10 Oct 2018

Introduced: 9 Oct 2018

CVE-2018-16737  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Alpine:3.15 tinc to version 1.0.35-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tinc package and not the tinc package as distributed by Alpine. See How to fix? for Alpine:3.15 relevant fixed versions and status.

tinc before 1.0.30 has a broken authentication protocol, without even a partial mitigation.

CVSS Base Scores

version 3.1