Improper Authentication Affecting linux-pam package, versions <1.5.1-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.96% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE316-LINUXPAM-2843012
  • published2 Feb 2021
  • disclosed18 Dec 2020

Introduced: 18 Dec 2020

CVE-2020-27780  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Alpine:3.16 linux-pam to version 1.5.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-pam package and not the linux-pam package as distributed by Alpine. See How to fix? for Alpine:3.16 relevant fixed versions and status.

A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.

CVSS Base Scores

version 3.1