Improper Privilege Management Affecting nomad package, versions <0.9.2-r0


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.42% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE316-NOMAD-2845298
  • published2 Feb 2021
  • disclosed12 Aug 2019

Introduced: 12 Aug 2019

CVE-2019-12618  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Alpine:3.16 nomad to version 0.9.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nomad package and not the nomad package as distributed by Alpine. See How to fix? for Alpine:3.16 relevant fixed versions and status.

HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver.