Out-of-bounds Write Affecting zlib package, versions <1.2.12-r2


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
RHEL
6.5 medium
Expand this section
NVD
9.8 critical
Expand this section
SUSE
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE316-ZLIB-2976176
  • published 6 Aug 2022
  • disclosed 5 Aug 2022

How to fix?

Upgrade Alpine:3.16 zlib to version 1.2.12-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream zlib package. See How to fix? for Alpine:3.16 relevant versions.

zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).