Cross-site Scripting (XSS) Affecting consul package, versions <1.9.5-r0



    Exploit Maturity Proof of concept
    Attack Complexity Low
    User Interaction Required
    Scope Changed
Expand this section
6.1 medium
Expand this section
Red Hat
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-CONSUL-3139483
  • published 29 Apr 2021
  • disclosed 20 Apr 2021

How to fix?

Upgrade Alpine:3.17 consul to version 1.9.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream consul package and not the consul package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

HashiCorp Consul and Consul Enterprise up to version 1.9.4 key-value (KV) raw mode was vulnerable to cross-site scripting. Fixed in 1.9.5, 1.8.10 and 1.7.14.