Missing Authorization Affecting consul package, versions <1.14.1-r0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-CONSUL-3148108
  • published 25 Nov 2022
  • disclosed 16 Nov 2022

How to fix?

Upgrade Alpine:3.17 consul to version 1.14.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream consul package and not the consul package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

HashiCorp Consul and Consul Enterprise 1.13.0 up to 1.13.3 do not filter cluster filtering's imported nodes and services for HTTP or RPC endpoints used by the UI. Fixed in 1.14.0.

References