Allocation of Resources Without Limits or Throttling Affecting jenkins package, versions <2.361.2-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.17% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE317-JENKINS-3142197
  • published23 Nov 2022
  • disclosed12 May 2022

Introduced: 12 May 2022

CVE-2022-22971  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade Alpine:3.17 jenkins to version 2.361.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jenkins package and not the jenkins package as distributed by Alpine. See How to fix? for Alpine:3.17 relevant fixed versions and status.

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.

CVSS Base Scores

version 3.1