Link Following Affecting rpm package, versions <4.18.0-r0


0.0
medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
6.4 medium
Expand this section
Red Hat
6.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-RPM-3144058
  • published 23 Nov 2022
  • disclosed 25 Aug 2022

How to fix?

Upgrade Alpine:3.17 rpm to version 4.18.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm package and not the rpm package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

A race condition vulnerability was found in rpm. A local unprivileged user could use this flaw to bypass the checks that were introduced in response to CVE-2017-7500 and CVE-2017-7501, potentially gaining root privileges. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

References