Out-of-bounds Read Affecting upx package, versions <4.0.0-r0


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-UPX-3144262
  • published 23 Nov 2022
  • disclosed 25 Aug 2022

How to fix?

Upgrade Alpine:3.17 upx to version 4.0.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream upx package and not the upx package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

A heap-based buffer over-read was discovered in the invert_pt_dynamic function in p_lx_elf.cpp in UPX 4.0.0 via a crafted Mach-O file.

References