Reachable Assertion Affecting upx package, versions <4.0.0-r0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-UPX-3144489
  • published 23 Nov 2022
  • disclosed 27 May 2021

How to fix?

Upgrade Alpine:3.17 upx to version 4.0.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream upx package and not the upx package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

An assertion abort was found in upx MemBuffer::alloc() in mem.cpp, in version UPX 4.0.0. The flow allows attackers to cause a denial of service (abort) via a crafted file.

References