Out-of-Bounds Affecting upx package, versions <4.0.2-r0



    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-UPX-3267268
  • published 3 Feb 2023
  • disclosed 12 Jan 2023

How to fix?

Upgrade Alpine:3.17 upx to version 4.0.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream upx package and not the upx package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

A Segmentation fault was found in UPX in PackLinuxElf64::invert_pt_dynamic() in p_lx_elf.cpp. An attacker with a crafted input file allows invalid memory address access that could lead to a denial of service.