CVE-2022-34293 Affecting wolfssl package, versions <5.4.0-r0



    Attack Complexity Low
    Availability High
Expand this section
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-WOLFSSL-3144599
  • published 23 Nov 2022
  • disclosed 8 Aug 2022

How to fix?

Upgrade Alpine:3.17 wolfssl to version 5.4.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wolfssl package and not the wolfssl package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

wolfSSL before 5.4.0 allows remote attackers to cause a denial of service via DTLS because a check for return-routability can be skipped.