Out-of-bounds Read Affecting wolfssl package, versions <5.5.3-r0


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Availability High
Expand this section
NVD
9.1 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-WOLFSSL-3144838
  • published 23 Nov 2022
  • disclosed 7 Nov 2022

How to fix?

Upgrade Alpine:3.17 wolfssl to version 5.5.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wolfssl package and not the wolfssl package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes. (WOLFSSL_CALLBACKS is only intended for debugging.)

References