Improper Input Validation Affecting zoneminder package, versions <1.36.31-r0


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-ZONEMINDER-3144655
  • published 23 Nov 2022
  • disclosed 7 Oct 2022

How to fix?

Upgrade Alpine:3.17 zoneminder to version 1.36.31-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zoneminder package and not the zoneminder package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

ZoneMinder is a free, open source Closed-circuit television software application. Affected versions of zoneminder are subject to a vulnerability which allows users with "View" system permissions to inject new data into the logs stored by Zoneminder. This was observed through an HTTP POST request containing log information to the "/zm/index.php" endpoint. Submission is not rate controlled and could affect database performance and/or consume all storage resources. Users are advised to upgrade. There are no known workarounds for this issue.

References