Cross-site Scripting (XSS) Affecting zoneminder package, versions <1.36.31-r0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ALPINE317-ZONEMINDER-3144656
  • published 23 Nov 2022
  • disclosed 7 Oct 2022

How to fix?

Upgrade Alpine:3.17 zoneminder to version 1.36.31-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zoneminder package and not the zoneminder package as distributed by Alpine:3.17. See How to fix? for Alpine:3.17 relevant fixed versions and status.

ZoneMinder is a free, open source Closed-circuit television software application The file parameter is vulnerable to a cross site scripting vulnerability (XSS) by backing out of the current "tr" "td" brackets. This then allows a malicious user to provide code that will execute when a user views the specific log on the "view=log" page. This vulnerability allows an attacker to store code within the logs that will be executed when loaded by a legitimate user. These actions will be performed with the permission of the victim. This could lead to data loss and/or further exploitation including account takeover. This issue has been addressed in versions 1.36.27 and 1.37.24. Users are advised to upgrade. Users unable to upgrade should disable database logging.

References