Integer Overflow or Wraparound Affecting gmp package, versions <6.2.1-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.46% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE318-GMP-5512452
  • published28 Jan 2022
  • disclosed15 Nov 2021

Introduced: 15 Nov 2021

CVE-2021-43618  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Alpine:3.18 gmp to version 6.2.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gmp package and not the gmp package as distributed by Alpine. See How to fix? for Alpine:3.18 relevant fixed versions and status.

GNU Multiple Precision Arithmetic Library (GMP) through 6.2.1 has an mpz/inp_raw.c integer overflow and resultant buffer overflow via crafted input, leading to a segmentation fault on 32-bit platforms.

CVSS Base Scores

version 3.1