Missing Authorization Affecting nomad package, versions <1.5.1-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.54% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE318-NOMAD-5515936
  • published15 Mar 2023
  • disclosed14 Mar 2023

Introduced: 14 Mar 2023

CVE-2023-1296  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade Alpine:3.18 nomad to version 1.5.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nomad package and not the nomad package as distributed by Alpine. See How to fix? for Alpine:3.18 relevant fixed versions and status.

HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.5.0 did not correctly enforce deny policies applied to a workload’s variables. Fixed in 1.4.6 and 1.5.1.

CVSS Base Scores

version 3.1