CVE-2023-4012 Affecting ntpsec package, versions <1.2.2a-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.45% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE318-NTPSEC-5877705
  • published1 Sept 2023
  • disclosed7 Aug 2023

Introduced: 7 Aug 2023

CVE-2023-4012  (opens in a new tab)

How to fix?

Upgrade Alpine:3.18 ntpsec to version 1.2.2a-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ntpsec package and not the ntpsec package as distributed by Alpine. See How to fix? for Alpine:3.18 relevant fixed versions and status.

ntpd will crash if the server is not NTS-enabled (no certificate) and it receives an NTS-enabled client request (mode 3).

CVSS Base Scores

version 3.1