Memory Leak Affecting privoxy package, versions <3.0.29-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.02% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE318-PRIVOXY-5514139
  • published23 Apr 2021
  • disclosed25 Mar 2021

Introduced: 25 Mar 2021

CVE-2021-20212  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Alpine:3.18 privoxy to version 3.0.29-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Alpine. See How to fix? for Alpine:3.18 relevant fixed versions and status.

A flaw was found in Privoxy in versions before 3.0.29. Memory leak if multiple filters are executed and the last one is skipped due to a pcre error leading to a system crash.

CVSS Base Scores

version 3.1