Improper Certificate Validation Affecting pgbouncer package, versions <1.16.1-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.12% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE319-PGBOUNCER-6110793
  • published8 Dec 2023
  • disclosed22 Nov 2021

Introduced: 22 Nov 2021

CVE-2021-3935  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Alpine:3.19 pgbouncer to version 1.16.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pgbouncer package and not the pgbouncer package as distributed by Alpine. See How to fix? for Alpine:3.19 relevant fixed versions and status.

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

CVSS Base Scores

version 3.1