Access Restriction Bypass Affecting gnutls package, versions <3.4.5-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.44% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE32-GNUTLS-1087014
  • published18 Mar 2021
  • disclosed27 Sept 2016

Introduced: 27 Sep 2016

CVE-2016-7444  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Alpine:3.2 gnutls to version 3.4.5-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnutls package and not the gnutls package as distributed by Alpine. See How to fix? for Alpine:3.2 relevant fixed versions and status.

The gnutls_ocsp_resp_check_crt function in lib/x509/ocsp.c in GnuTLS before 3.4.15 and 3.5.x before 3.5.4 does not verify the serial length of an OCSP response, which might allow remote attackers to bypass an intended certificate validation mechanism via vectors involving trailing bytes left by gnutls_malloc.