Improper Input Validation Affecting libxtst package, versions <1.2.2-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.29% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE32-LIBXTST-1087067
  • published13 Dec 2016
  • disclosed13 Dec 2016

Introduced: 13 Dec 2016

CVE-2016-7952  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Alpine:3.2 libxtst to version 1.2.2-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxtst package and not the libxtst package as distributed by Alpine. See How to fix? for Alpine:3.2 relevant fixed versions and status.

X.org libXtst before 1.2.3 allows remote X servers to cause a denial of service (infinite loop) via a reply in the (1) XRecordStartOfData, (2) XRecordEndOfData, or (3) XRecordClientDied category without a client sequence and with attached data.