Out-of-Bounds Affecting libxvmc package, versions <1.0.9-r1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.45% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE32-LIBXVMC-1087069
  • published13 Dec 2016
  • disclosed13 Dec 2016

Introduced: 13 Dec 2016

CVE-2016-7953  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Alpine:3.2 libxvmc to version 1.0.9-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxvmc package and not the libxvmc package as distributed by Alpine. See How to fix? for Alpine:3.2 relevant fixed versions and status.

Buffer underflow in X.org libXvMC before 1.0.10 allows remote X servers to have unspecified impact via an empty string.